Compatibility with SCCM 2007

Jun 16, 2014 at 2:16 PM
I am still running SCCM 2007. I've been using the smsclictr.automation.dll library for years. Does this version still support SCCM 2007 or should I stick with the older version (1.1.3.4) that I've been using for my other application?

Thanks for sharing your excellent work!!
Coordinator
Jun 17, 2014 at 1:42 PM
smsclictr.automation.dll was made for SCCM 2007; sccmclictr.automation.dll is designed for CM12. smsclictr is using WMI to connect remote machine where sccmclictr is using WinRM. additionally in sccmclictr, the function-results will be cached for further use and to improve Performance.

I would also recommend to download the latest source code and then compile it; the compiled downloads may not be up to date...

Regards

Roger
Jun 23, 2014 at 2:37 PM
Thanks, Roger. I've built smsclictr.automation.dll from the source to use in my project. Thanks again for all your work on this!